Cannot record or execute tests- driver issues

@testproject HI All,
i started to face an issue in which i cannot start the recorder:


i tried to download the latest chrome driver and put it on testproject folder as instructed BUT the issue still occur. anyone else encounter this issue and have a solution?
@eldar @asaf.saar please let us know if this can be resolved.

1 Like

Having this issue as well. I have followed all steps in that article and still running into the same issue in Chrome. Sounds like the only solution for now is to download an earlier version of Chrome and run it off that. Let me know if you find any other information. Thanks!

Yep, this is only one solution for this so far. Downgrade chrome to 104v and disable auto update for chrome

1 Like

Do you have any suggested steps / articles on how to do so? I just downgraded to Chrome 104v and disabled auto-updating but every time I register my agent, it keeps detecting Chrome 105, even though I’m sure Chrome is showing me v104.

I appreciate your help :slight_smile:

Hm… u added 105v chorme driver in agent folder ? Perhaps u or tp added 105v in folder. U need download webdriver for 104v exactly as ur chrome version and paste in agent folder. See in the docs link as wrote in screenshot

Thanks. I suppose I’ll just wait. I don’t think my entire team will be willing to have to deal with these work arounds. Not worth the time. Thanks for your help Wolfgang! :slight_smile:

This is another sign that TestProject is not actively fixing issues/ support issues and eventually will not continue to live. Such a shame that this tool is ending like that.
I hope that people at TestProject / Tricentis will do the right thing and keep on developing / supporting TestProject.
This is an incredible tool

1 Like

Agreed. It’s my favorite I’ve used so far and wish it would at least have some stability… I’m hoping for the same thing.

@testproject @shai.glatshtein_prd @marat @eldar @Amit.Lacher @amit.yahav @meital.matsafi
this issue still occur and prevent us from executing/ recording tests . can you please assist on this matter?

I have restarted the agent & everything is working fine on my end. I am able to record & executed jobs.

The issue still occur with latest chrome 105. Tried it out now. The driver is downloaded but the recorder is closed and an error appear …

downgrade ur chrome to 104 and will be file

To downgrade from the newest Chrome version is not really an option with the security issues in the old versions.
Is it possible to tell the agent which web drivers to use? Or which Chrome version?

Then u need to wait when TP fix it… with 105v TP not working now. I think issue in the web driver version… find a solution yourself, i can’t help u if u not want downgrade ur chrome

That’s exactly what I am doing, I try to find a solution. That’s why I am asking if there is the possibility to tell the agent/recorder which driver version to use.
I tried it with chromium and also manually saving an older driver version, but tp always replaces them. So maybe somebody knows where I can change something to tell tp which version of drivers to use

I understand. But here only 2 solutions. 1st- Downgrade chrome 104 and below. 2nd - just wait a new version or when TP fix it. It’s all

There is no documented official way to downgrade Chrome. Do you have any trusted guide where to get the 104 offline installer for the binaries?

I tried installing Chromium, but this is not detected by the agent.

not sure that Testproject will fix it. the tool is recently not stable (seems related to tricentis acquired testim.io)

It really got fixed, :o it’s working in the new Chrome version again. At least for us…