TestProject Forum

Can TestProject connect to Database?

Hi…I am trying to connect to an Oracle DB using the add-in. I have tried supplying

I am getting this error: access denied (“java.io.FilePermission” “S:\tnsnames\ojdbc.properties” “read”)
S is a mapped network drive and the file referenced in the error does exist in this location. any idea why it would be looking for this file? Thank you.

Hello, we updated the addon.
Please go to the addons page, update the addon and try again.
Let me know if the helped

Ok I will do that. Thank you very much!

Hi, I updated the add-in and the test agent. Now when I test the connection I get the error IO Error: The Network Adapter could not establish the connection.

Hello Trish, please make sure you are using the latest version of the addon

Hi Ran. I have the latest test agent and the latest version of the oracle add-in installed. When I executed a test with the test connection to oracle database step, the test is failing with this error:
Listener refused the connection with the following error:
ORA-12514, TNS:listener does not currently know of service requested in connect descriptor
I have run the following script against the db to make sure that the value for ServiceName is correct in the connection information
select value from v$parameter where name=‘service_names’;
This returns the value that I have specified in the ServiceName field
I have made sure that the port number is correct as well. Any ideas on what to try next? Thanks

Hello

I would like to run some tests against oracle, do you have any support for oracle?

Hello @apimmigrationsp
Yes we do, search for Oracle in the actions menu to see the actions to Query Oracle DB.

Hello @trish.jefferson.

The error comes when trying to establish the connection to the database, and that is where the error message is coming from.

Can you run the following queries and check if there are other service names listed in your database and try using them?

select name from V$SERVICES;
select name from V$ACTIVE_SERVICES;

Hi…David. I ran both of those queries and both returned the same results. So all of the services are active and I checked with the db admin and I am using the correct entries for the connection parameters. So the admin indicated that the issue is likely a firewall or networking issue. Can you recommend changes that would resolve this issue? Thanks.

Hi @trish.jefferson.

Is it possible for you to connect to your Oracle Database using a client like Oracle SQL Developer just to be sure if it’s a network issue?
You could check your tnsnames.ora file for the service name or you can try to use the command ‘tnsping DBNAME’ to check your connectivity with your Database.

If you are able to connect using the client, can you please send the input fields as you’ve entered them to support@testproject.io so I can check the addon, and possibly schedule a meeting to review the issue?

Hi David…I am able to connect to the oracle database using oracle SQL developer that is running on my local system using the credentials that I have entered into the ‘test oracle db connection’ step. Because our database contains confidential client information, I cannot provide the username and password that I have entered to connect. The username and password are my account credentials and I can successfully connect to the database. I will send the other information that I have entered support@testproject.io. Thanks

Whether we support DocumentDB?

Hello @gourav.sonare
We will check about adding support for such DB as well.
Thank you.

Hello,

We support MSSQL, MySQL and PostgreSQL. You can find more details here: MSSQL Addon: https://addons.testproject.io/mssql- database

If any one want to learn SQL Server Training, please let me know, I will help you.

Thanks & Regards,
Anita

@creatoranita @ran.tzur Do we have any support for Microsoft SQL server?

Hello Arjun,

Good Afternoon,

I am not getting you could you please tell me in brief.

Thank you

Hi @creatoranita
From the Above Posts, I understand testproject supports MSSQL, MySQL and PostgreSQL databases. My requirement is to have an integration with the Microsoft SQL server (Refer below). Do we have an addon supporting this?
image