TestProject Forum
Powered by leading experts in the test automation community

Can TestProject connect to Database?

Is there a way TestProject can connect to local database?

Hi @mnguyen,

Sure there is!
We have 3 addons that provide you a way to test the connection and send queries.
We support MSSQL, MySQL and PostgreSQL.

You can find more details here:

  1. MSSQL Addon: https://addons.testproject.io/mssql-database

  2. MySQL Addon: https://addons.testproject.io/mysql-database

  3. PostgreSQL Addon: https://addons.testproject.io/postgresql-database

Let me know if you’ll need my help with that :slight_smile:
Amit

We use DB2 database. And how do I use the addon to SQL against it?

Hi @mnguyen.
We added DB2 in our addons development list and I will be glad to update you once it will be released for you and everybody who are working with the same DB type :slight_smile:

Thank you very much! :smiley:

Hi @amit.yahav,

i would like to run some tests againt oracle, do you have any support for oracle?

regards,
Rajesh

Hey Rajesh, we are currently working on one.
It will be ready in a couple of days :slight_smile:

Best Regards, Ran.

Hello,

The oracle database addon has been released,
You can find it in the addon section.

Happy testing,
TestProject team.

1 Like

Hi David,

I’m unable to connect oracle db in my test case.
where do i specify service name in test sql/send sql action of oracle db??
My Db connection is having service name whereas oracle add on is just asking for hostname, port, username and password.

Please let me how i can connect it

Hi Vivek, try to use the following syntax in your host name option in TestProject addon:

HOSTNAME:PORT/SERVICENAME

or

HOSTNAME/SERVICENAME

let us know if it helps

Hi Vivek,
If the solution mentioned above does not work for you,
Can you try adding :SERVICE_NAME or /SERVICE_NAME to the port field and updating us if that worked for you?

Hi David,

Tried your solution, it didn’t worked and i’m getting input string error in port field during execution.

Hi Mark,

HOSTNAME/SERVICENAME is going in infinite loop. I have to abort it myself.

HOSTNAME:PORT/SERVICENAME is failing but i’m not getting any proper message in failure step.

Conclusion - both solutions are not working.

I’ve updated the addon with SID and Service name fields, please install the latest version and let me know if it works for you now.

I’m getting below error message -
Failed to read file signature

Please shut down the agent and then go into the agent’s folder in %appdata%->TestProject->Agent, and clear the contents of the addon folder, then start the agent again. If the issue persists please send us the agent logs to support@testproject.io

Are you using the latest agent version 0.60.21 ? If not then please update to it as it is the one needed to be able to use this addon.

Hi David,

Yes i was using old version of agent. i uninstalled current one and installed new one which solved my problem.

Thanks for the help :slight_smile:

Glad to hear !
Please don’t hesitate to contact us if you need anything else. :slightly_smiling_face: