TestProject Forum
Powered by leading experts in the test automation community

Broken login page without any web element

Hello,

When I am trying to run this command:

Navigate to ApplicationURL

The login page opened is broken without any web elements. When I tried to open the same link on the chrome browser, it worked fine. I am not sure what is causing the broken link. I tried Mac and Windows PCs.

Please see this screenshot. Any help will be appreciated

.
Regards,
Shah

Hi @kshahid,

Can you please share this URL with us? We would like to test it in our end.

Thanks,
Amit

Hi @kshahid,

I will summarize our conversation in the TestProject chat here as well:

"I investigated your issue and I found that your website checks if the URL that its currently in, is the same as the top of the window.
Since we are presenting your website inside an iframe, the URL is different and your website has a logic of changing the top, which is our iframe. You cannot access to the iframe and this throws an exception.

We are currently working on a new recorder that won’t present your website inside a recorder, so this issue should be gone by then. At the moment, you can create the elements in the login page manually to complete the login flow. Although it won’t work in the recorder, it will work once you will run it from outside the recorder."

Kind regards,
Amit