Appium Server is Not Running (Appium Connection Problem?)

Hi, I had been using TestProject for around 4 months now, and changed a new computer. Thus, when establishing new laptop, I installed Java, TestProject Agent, and of course Appium. But the server is still not running every time I tried to view/record device, it is mirrored and then shows the error, with the android device connected to the agent. (first image) With the old laptop, an app called Appium Settings downloaded in the Android device is called and it started just fine.

So I am wondering if the procedures to download Appium hinders the process, since from this blog, the Appium is supposed to lead us to the Appium installer, yet the link redirects us to Appium Server GUI installation instead.

So I would like to know if this caused the inability to run the appium server when I tried to record the test from physical device, or is there any way/any files I might not have downloaded to solve this issue? Thank you in advance!