TestProject Forum
Powered by leading experts in the test automation community

App not installed [iOS/Android]

Hi,

I receive the following errors while starting a test on your web-ui in case the app is not installed on the device:

  • iOS: App not installed: App not installed: App {myBundle} is not installed
  • Android: App not installed: Requested package was not found on the device

I added several versions of my app in the applications-collection and the tests are connected with one of them. I thought, this will lead to an automatic installation. Where do I need to enable automatic installation?

Following topic don’t work for me: Automatically Installing Android Application - I don’t see the reinstall-option.

Thanks in advance

Hello @patrick.teufel,
How did you upload your apps in the application section?
Did you upload it manually or uploaded APK/IPA? Or is the application already installed in the device?

Hello @itamar.klein,

I tried uploading the app “From Device” and (another version) via “Upload APK” (i.e. Android). Both ways doesn’t reinstall the app if it’s not already installed.
But you gave me another interesting point: I am able to add an android application via “Add manually” with only the three strings Name, Package and Activity - without even uploading a .apk! This means TestProject maybe doesn’t save the real APK and the other upload possibilities are comfort features to only extract the strings Package and Activitiy.

If thats the case it’s impossible to let the test automatically install the application.

Or is the application already installed in the device?

No, I don’t want to manually install a specific version of my application. Instead some kind of ‘reinstall’ step should make sure, that the specific (and already uploaded) application for this test is installed in advance.

After you uploaded the app, regardless of the way you did it, it will be saved in your account and you don’t need to upload it again.
And when you run your test you should be able to see the option to reinstall app before executing.
Is it not the case for you?

image

1 Like

Thanks!

There is no ‘Reinstall app before executing’ options so I tried to upload the application again.
In ‘application’ the details for my new uploaded application are now filled with my .apk/.ipa instead of the bundle-Id(iOS) or Package/Activity (Android). If I build a new test which depends to this app reinstall is possible and works!

I think I made the following mistakes:

  • I didn’t uploaded the .apk/.ipa at TestProject (even if I wrote it in my previous message :/). Maybe I was so confused that I uploaded .apk/.ipa only on other plattforms and not on TestProject (I currently research several test plattforms).
  • I expected the .apk/.ipa can be extracted at the upload “From Device” step (Yeah, sounds stupid …). In fact the “From device” and “Manually” action only creates kind of references. Tests based on those ‘reference’ applications won’t be able to install an application because they don’t know about the real .apk/.ipa.

Thanks for you help!