TestProject Forum

Android Device (Samsung - SM-G950F) disconnects by recording teststep

Good Morning,

we have connected our Android Device (Samsung - SM-G950F with Android 28) to our agent successfully.

But If i want to record a teststep, then the device disconnect from the agent and i get the failure:“Device disconnected”

We reconnected the device over 10 times and we get the same failure.

All USB Debug Settings are done!
Which Log Infomration / files form the agent i should post here?

Thanks for your Help

Hello @daniel.sonne
Can you please send a short video if possible as well as the agent logs to support@testproject.io
You can find the logs at the Agents page, near the agent you have 3 dots, click on them to download the logs.

i sent the mail with the logs an 2 screenshots. thx for your help!

Hi Daniel!

We had a meeting today, we looked over the logs you sent us and the logs from today.
I couldn’t detect any critical issue with the Agent, I’ll try to clarify with more details below.

In my opinion, the issue seems to be related to the device or an application installed on the device.

In both the logs from last week and today we are seeing multiple connect/disconnect events from your device that happen in a very short amount of time for a period of 10-20 seconds.
This alone indicates on a very unstable connection.

  • Could it be that the cable the device is connected with causes this?
    something must be causing the device to show this behavior.

As you have told me, a different device worked on that machine with no issues so I can only assume that the issue you are facing now is related to this specific device and not the Agent itself.

Please try to work around this issue, there are many things you can try -

  • Changing the cable connecting the device.
  • Restarting the device.
  • Factory resetting the device.

Please update me if you have any new information that might help us continue with the investigation.

Tzah.

Hi,

i have good news.

We change the USB Port on our computer where the agent is installed.

While i start recording i got the message:

“Reset application confirmation
Your automation might not work properly if the app has cached data or saved state such as a logged in user, configured settings, etc…
Would you like to reset your App and return to its pristine condition?”

I clicked “Yes” an now it works and i can record on the device!

Thanks for your help!

Greetings Daniel

1 Like