TestProject Forum
Powered by leading experts in the test automation community

Android Device not detected

"I’m stuck on the creating new test in which my device is not detected even though my phone is in developer mode or debugging mode is enabled. I tried it in both Google Chrome and Safari (MacOS desktop) but the same thing happened. Anyone can help me with this issue?

Thanks!

Hello,
In order to run tests on your device an agent must be installed and registered.
Did you downloaded and registered TestProject Agent for your operating system? (located under “Agents” tab)
After agent registration, connect your device to your pc and a pop up should appear on your device asking
if device should be trusted. click “trust this computer” and your device should be detected afterwards.
After doing those steps please upload a screenshot of the agent’s tab if your device is still not being detected.

Yes I have installed an agent and registered. I connected the device but no popup appeared. Actually I’m on MacOS using Android Devices which still has issues. I believed that popup “Trust this computer” will only appear if I’m using an apple devices connected to my Mac. Here’s the screenshot https://ibb.co/ipwYb8

Hello,

Could you please post a screenshot of your USB devices?
Open “System Information” application, expand Hardware -> USB

Thanks.

Here’s the screenshot of my device hardware. https://ibb.co/hQCLOo

Unfortunately, if your Mac fails to detect the device attached, TestProject won’t be able to communicate with it either.
You can try switching to another USB port or using a different cable.

Okay, I’ll buy different data cable. I hope it will work. Thanks!

I solved this issue by using new data cord.