Agent not enabling android emulator

I’ve created an emulator in android studio, the adb device list sees it, but the TP agent does not. I also had one attached a while back, and when I try to use that one that’s listed in the devices for my agent, it won’t connect. I’ve tried cold starting it in studio, I’ve tried closing and reopening my agent, logging out and logging back in. Any suggestions would be hugely welcome. Thank you!

Machine OS: Windows 10
Android studio version: Android Studio Bumblebee | 2021.1.1 Patch 1
Build #AI-211.7628.21.2111.8139111, built on February 1, 2022
Device 1: Pixel 3a XL API 30
Device 2: Pixel API 29
TestProject Agent version: 3.4.2

*edited to add TestProject agent version

Hi @georgina.covarrubias ,

Welcome to our community :slight_smile:

First, I would like to know if you got any error message?

If you do, please share a screenshot it will be helpful.

Please follow this guide and notice if you didn’t do it correctly.

This is how you start an emulator from android studio:

First, you install android studio from here: Download Android Studio and SDK tools  |  Android Developers

After installation you go to tools-> AVD Manager:

Then you do the following:

Select the device you wish to emulate, then select the version, after that, you can fine-tune it to your desires or just open the emulator and start testing.

If the agent does not recognize the emulator after installation, please restart your agent.

Let me know if you followed all the instructions and the issue still occurs.

Hi Alex! Thank you so much for responding. There’s no error message and my setup looks like your capture (thank you for including that, it helps to compare), but my device is still not listed in the devices for my active agent.
I’m not sure how huge a difference it makes, but I also tried both quick and cold boot based on articles found on google, but that hasn’t helped connect the emulators to the agent either. Is there anything else I can try?
Thank you again for responding!

@georgina.covarrubias

Did it happen to you in the past?

Please follow these two solutions:

  • Try to restart the emulator and reproduce the issue.

  • Reinstall the emulator and reproduce the issue

Let me know if the issue still occurs.

1 Like

Hi Alex! I’m not sure what changed, but it’s working now, thank you! :mega: :raised_hand_with_fingers_splayed:

@georgina.covarrubias Happy to help :grinning: