TestProject Forum

Agent cli headless browser window size

Hi
seems that something changed in the latest agent releases and running with headless Chrome the default window size is now 800x600. In non headless it defaults to the native resolution though, but we need to run headless.
Is there a way to specify the window size globally for all tests when running via the cli? a parameter in the settings.yaml perhaps, I can’t find anything in the docs though

Hello,
Same issue here. I have a lot of testcases that are failing all of the sudden due to the default window size.
I can’t spend all that time to change and readapt all my testcases with a test step that changes the window size … Isn’t there a parameter to change this globally ?

@SjakieMaksym and @daniel.puchianu

To better troubleshoot it I have a few questions:

  1. What is your Chrome version?
  2. What is your operating system type and version?
  3. Is the environment itself (where the Agent is running) headless? such as server linux or Docker?
  4. Are you executing locally or via SauceLabs / BrowserStack?

Thanks.

Hi,

  1. Chrome version is 90.0.4430.85
  2. OS is Ubuntu 18.04 (gnome desktop)
  3. Env is a desktop machine
  4. Tests are executed locally by passing downloaded yaml files to the agent cli with this cmd testproject-agent run -r=LOCAL_REPORT -rd -p parameters.csv --browser=CHROME_HEADLESS my-test.yaml

Thanks

@SjakieMaksym

Thanks for the information, I can see that it reproduces.
Will keep you updated regarding the fix.

@SjakieMaksym and @daniel.puchianu

Please download and install the latest Agent 2.3.7 with a fix.

Seems ok now
Thanks!

Great, thanks for reporting this and verifying the fix.