ADB functions are not working

Hi ,
I’m working on a mobile app automation , where the recorded script used to work witha command “Type text using adb” and sending key as 1…but now I see the step is passed and the value is not passed in the app later in the next steps it is failed due to continuation.I tried uninstalling and installing “mobile extensions” addon and also tried type text if visible command also…but it is same.
IIs this due to other issues team is facing

Hi @shyamala.turpati are you able to show the adb command your using.
Also is there any elements that might be blocking the signal?.
Have you tried the standard type text?

Before sending the text I’m making sure the element is found by clicking on it…I can see the keyboard movements on the screen…we are sure that the element is recognized…

its been awhile since had to play with the adb commands, but from an automation point via ci it would be something like:

adb shell input text 'hello world'

“most” android input field dont need you to click inorder to send text.

I also noticed that your element is a ‘view.viewgroup’ maybe worth ensuring that that is truely the element that expects input.
For this I usually click the explorer, move my mouse to the element I want to interact with the press shift twice and explore the elements until find the expected.

Summary:

  1. try using appiums default ‘type text’:
    image
  2. if adb type text is essential try checking the details on the failed action to see if something isn’t as expected
  3. ensure the element your attempting to interact with can recieve the text ( some developers put a transparant element behind keyboard so if user taps it will dismiss the keybaord)


I’m not getting the default “type text” :frowning: Should I install some addon ?

  1. I see the element is recoginzed and it is sending the text but I dont see the action is performed on my app(Like the text is not written on the app). It goes to next step where it is searching for a pop up and it s not finding it since the before step is not completed.

  2. I tried in both the ways by not enabling the keyboard and by enabling it…it is same.

@shyamala.turpati
You cannot see the default type action because you are searching for elements with a filter.
Clearing the filter should show you all available actions.https://assets.grammarly.com/emoji/v1/1f642.svg
*Since the recorder created this filter automatically, it might mean that the standard type action won’t work in this case.

What would be the best solution ?

@shyamala.turpati
Copy the element locators and create a step with the ‘type text’ action manually.