Getting black screen while recording test

  • 3 Replies
  • 756 Views
*

sadik

  • *
  • 12
Getting black screen while recording test
« on: August 06, 2018, 22:13:39 pm »
I have register test agent with SDK and connect device with System.

I created test and started recording, but I noticed that black screen displayed while app is opened and screen is unlock.

Can you please suggest on above issue.

Thanks
Sadik

Re: Getting black screen while recording test
« Reply #1 on: August 06, 2018, 22:29:33 pm »
Hello,

Please make sure you have no other screen mirroring software running simultaneously.
Try viewing your device screen from "Devices" tab on Agents page.
If nothing works, please share your Agent logs.

Thanks.


*

sadik

  • *
  • 12
Re: Getting black screen while recording test
« Reply #2 on: August 07, 2018, 18:22:09 pm »
I have not opened any other screen mirror, ASM launched only when getting black screen so I can show you my device screen.

Also, I have one question how I to get element details using SDK, I observed that we can get only default xpath, id. If we want to update xpath, then how do I get element details.

Thanks,
Sadik

Re: Getting black screen while recording test
« Reply #3 on: August 07, 2018, 22:17:28 pm »
Hi Sadik,

Can you please send us your logs (you can download them in the Agents section. Next to your Agent, on the right side - you will see an arrow down icon, click it to open the option to download the logs).
In addition, can you please restart your mobile device.

As for your question on how to get element details using TestProject SDK, see this topic: https://forum.testproject.io/index.php/topic,598.0.html.

Thank you,
Karen

 

Sitemap 1 2 3 4 5 6 7 8