[RESOLVED] Android device not detected from my Windows 10 computer

  • 3 Replies
  • 505 Views
*

pat

  • *
  • 0
Hi,

When I tried connecting my Android device to my computer, it seems that TestProject does not detect my Android device.

I tried connecting both a mobile phone and a tablet, the same "No connected devices" was shown on TestProject.

Troubleshooting:
Note: I tried restarting TestProject and also verified that there are no running anti-virus on my system.

Verification:
I then tried using Android Device Monitor to verify if my device were recognized by my system. Both the Mobile phone and tablet were detected by Android Device Monitor.


Agent Device information===
Agent: Windows 10.0
TestProject: 0.41.22
Browser: Firefox 56.0.2

Android Device information ===
- LG G2 (Android 4.4.2)
- Sony Tablet S (Android 4.0.3)

Thanks in advance.
« Last Edit: July 19, 2018, 17:53:22 pm by pat »

Re: Android device not detected from my Windows 10 computer
« Reply #1 on: July 19, 2018, 15:25:59 pm »
Hi thank you for the details.
Can you make sure your devices are in debugging mode when the usb connected?
In order to use your devices in TestProject platform, you need to enable usb debugging on your device (located in 'Developer options').
Please check our tutorial when you create new mobile test there is an explenation how to do it (see attached). 

*

pat

  • *
  • 0
Re: Android device not detected from my Windows 10 computer
« Reply #2 on: July 19, 2018, 15:29:00 pm »
Hi ranw,

Thank you for your response.

Yes, I was able to verify that both f my android device has its USB debugging enabled.

This can be seen from the screenshot above that the `adb` command was able to identify my device.

Furthermore, I was able to test compiling and uploading an android app to my device without any problem.

*

pat

  • *
  • 0
Re: Android device not detected from my Windows 10 computer
« Reply #3 on: July 19, 2018, 17:52:55 pm »
== RESOLVE ==

After reinstalling Test Project, I was able to see that my LG G2 is being detected by TestProject already.
(LG G2 (Android 4.4.2))

As for the Sony Tablet S (Android 4.0.3), it seems that cause of the problem was due to the Android version not being supported.

It was mentioned that TestProject supports only Android 4.4 and greater.

Thank you.

 

Sitemap 1 2 3 4 5 6 7 8