TestProject Forum

TestProject Platform => TestProject SDK => Topic started by: aden_collector on May 16, 2019, 15:38:06 pm

Title: Get error installing the TestProject SDK for C#
Post by: aden_collector on May 16, 2019, 15:38:06 pm
I am trying to install the TestProject SDK using the following nuget command in Visual Studio 2017:

Install-Package TestProject.SDK -Version 0.50.0

I receive the following error:

Install-Package : Could not install package 'TestProject.SDK 0.50.0'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.6.1', but the package does not
contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.
At line:1 char:1
+ Install-Package TestProject.SDK -Version 0.50.0
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

I have tried using .NET framework 4.5.2 and 4.6.1

I've also installed the following .NET software per the gitub site:


Also I've installed the dependencies listed in the nuget page.

For another approach, I've downloaded the C# SDK solution on Github called TestProject.SDK.Examples.IOS.Test.

I've tried to build it but get the following error:

Package TestProject.SDK 0.50.0 is not compatible with netcoreapp1.1

In Project Properties, Target Framework, I can't select .NET Core 2.1 even though I've installed it.
From searching stackoverflow.com, this seems to be an issue with VS 2017.

Title: Re: Get error installing the TestProject SDK for C#
Post by: amit.yahav on May 16, 2019, 16:15:24 pm